Full Slider
  • Hi I am using the full slider module, it works well on the home page but when i install it on other pages it distorts the page, doesn't show the image and moves everything down the page. Any ideas as i've tried literally everything. If i take away the HTML fragment or the code the page restores back to normally.
  • Hi,

    Thanks for buying :)

    we'd need to see the page if possible so that we can offer suggestions on how to fix it. If the site's not live yet you can upload a problematic page to a test area on your server by following the instructions here: http://www.seriftuts.com/webplus-tutorials/creating-a-sub-directory-for-website-testing/

    Neil
  • yeah that's fine i will upload it to the server now and send the link. I've been trying to solve this for 3 hours and i am sure it's something simple.
  • Fear not, we should be able to sort things for you :)
  • Excellent the link is:

    mw.101366testersite.co.uk - the home page works fine but if you hover over domestic and click on property you will see the issue.

    Thanks for the help
  • Hi,

    I think your problem is a path issue and the code calls from within your pages cannot find the relative files to call. I notice near the top of your source code, you are calling files outside of the root via ../folder/file

    If you check the code for where you are calling the full width slider files from, they are just a simple file path call with no folders so your link from the domestic page needs the slider files to be in the same directory as your html page as shown from both your code call and the URL address the page is expecting the files to be

    <link rel="stylesheet" href="full-width-slide-styles.css">

    But your page is expecting it to be here - http://mw.101366testersite.co.uk/domestic-clearance/full-width-slide-styles.css - but if you click that link, you'll get a 404 error (page or file not found) so therefore, the page will not show as it should do.

    The actual path to your css file for the slider is here - http://mw.101366testersite.co.uk/full-width-slide-styles.css

    So in a nutshell, if you get rid of the folder called domestic-clearance and keep all your html pages in the same directory and not sub folders and make the link to it as http://mw.101366testersite.co.uk/property-clearance-medway.html and not http://mw.101366testersite.co.uk/domestic-clearance/property-clearance-medway.html then the slider should then work

    If code calls DO NOT match exactly where the files are or should be, then you will always have issues with things not working how they should.

    Hope this helps a little
  • I see, that worked a treat! We don't actually make websites with these type of directories but the customer requested it hence why we've never noticed the issue. I can't believe i didn't think that was causing the problem! Thanks for your help.
  • My pleasure and glad we could help ;-)

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion