Full-Width Slider Addon from NJ: Addons Collection 2
  • Good evening, Community:
    I'm building a new project in WebPlus X8. I originally installed NJ Addons Collection I & II under WebPlus X7. I copied all of the addons (collections I & II) from X7 into the assets folder in WebPlus X8. I only run WebPlus X8 on my PC. WebPlus X7 has been uninstalled.
    Question: are the instructions for 'Adding the code' contained on the .PDF support file for 'Full Width Slider for WebPlus' found on the Collection II CD valid for use in WebPlus X8? I have followed the instructions correctly but when I attempt to copy the 'Full-Width-Code.txt' from the clipboard into the page code (Alt + S), the clipboard content will not paste into the page. Is there another updated version of the Full Width Slider that will work with WebPlus X8? Thanks for any assistance and for your time. NealO
  • Hi Neal,

    First make sure you have "Show Default Text" Enabled (Check image below)

    image

    Also remember, you cannot paste any code to the source view, other than the white space areas

    The addon information should be the same for X8 as it is for X7
  • Thank you, Mick.
    It's not working for me. I have "Show Default Text" enabled on the page, but when I try to paste the Full-Width-Code text onto the page, it doesn't happen. I get a tone from my PC but nothing pastes onto the page. Any ideas as to why my copy & paste does not work on the code page?
  • Hi Neal,

    The only time you will get a ping sound from your PC when pasting code to a source view of your page is when you are in the wrong place and it simply wont let you

    I'm not sure if you are adding it to the master page body start (if wanting the slider on all pages) or just the page body start but because I'm not at my regular work place and can't remember the exact code names, check the help file and double check to make sure you are using the correct place to paste to

    So for instance, if the help file says copy and paste the code "After" the <!--Page Body Start--> locate the exact line of code via ALT+S and then place you cursor "After" the last > and press enter on your keyboard, this will create a new white editable area underneath the quoted code, where you should then be able to paste the code you have copied.

    Let us know if that sorts your problem out
  • Mick:
    I've tried to create a one-space blank field right under by inserting my cursor directly after and pressing Enter. It just doesn't create a new blank field under . I just keep getting that PC tone. However, I can create a blank field by pressing Enter at the end of this line below:

    .slide-container .slide-desc > p a.more { color: #D3D3D3; } /* Caption hyperlink colour */.

    This line is above though. I am not using a Master Page with my site. The original Master Page became corrupt. The site functions well inspite of no Master Page. I am at a loss as to why my code page will not let me create any blank field spaces when I press Enter?. This is a tough one.


  • The only thing I can suggest is you send me your file so I can take a look at it

    Use the menu of Webplus of - File > Save as a Package (so nothing gets left out and I'm working with the same thing you are.

    Once saved, upload it to my dropbox here - https://www.dropbox.com/request/XbskJqTrcL1QQjEhhhP4

    If I can find out what the issue is I'll either email you or post a response back in this thread.

    Hope this helps
  • First, thanks for standing by with me on this, Mick. Here's how I resolved the issue. I opened the same template and stripped down the Home page. New template includes fresh Master. I added full width slider frag box on my Home page only. Opened code for page (Alt + S) and voila, I was able to paste the clipboard code directly under . I loaded my FWI's and went to browser preview. Works beautifully!!! Great addon. Again Mick, thanks for being so generous with your time & expertise. This ends this thread.
  • No worries Neal we do try our best to accommodate and thanks for the update, glad you managed to sort it ;-)
  • Hello Mick:
    I hope I may impose on you for your expertise. If you re-read this thread, it has to do with the full-width-slider issue I was having recently. It seems I'm having the same problem again whereupon I cannot create an editable space following the line of code in green = . I've uploaded my WebPlus X8 file (as package) including the source folder to your dropbox. I wish to use the F-W-S addon to display the clients luxury home images. If only I could create that space following . It worked for me on another project I was working - why not this one???
    Thanks for your time. NealO.
  • In reviewing my post I noticed that the forum dropped the code I originally included in the text which was Page Body Start. This example excludes the greater than symbols.
  • Neal,

    1) If you cannot add code, then you may not have the default text showing when you open the source code editor (ALT+S) If this is the case, with the source editor open to view code, click to toggle on or off the menu button of "Show Default Text" clicking this button will either show or not show default text areas in the source view editor. I can certainly add code within the file you have sent

    2) The full width slider would not work correctly anyway with the design you have and the fact you are using one of our other addons "Background Gallery" and showing images in a gallery slide show via the full browser width

    What does work here if you want to try it at your end is this. Use the file you have at present and on the home page where you have the frag box for the full width slider added, make the frag box almost full width of your page and also at a height that will fit comfortably under your text box of "Welcome to our homes" and above any footer content, my test here, the frag box dimensions are 960 wide x 400 high. Then copy the code for the image calls from the text file that accompanies the full width slider addon which you have already tried to copy and paste, only this time, don't use the ALT+S, just double click the newly sized frag box to open it and click the button to paste the code directly to the "BODY" section of the frag box.

    The full width background gallery still works and you should now also have a page width slider working, rather than a full width browser slider. That is about your only option you have due to what else you have running side by side as addons which will clash with one another due to what they do.

    Hope this helps
  • Mick, copied & printed your thread. Will get back to you with results. As always, thanks much.
  • Mick:
    Brilliant!!! I loaded 19 fresh images and changed transition/dwell times. For the most part, each image transitions smoothly one at a time - but I have noticed that the slider will skip images by a two-count; e.g.: will start at first image and skip directly to the third, and so on. About half-way through the image cycle, the slider will then trans to each image one at a time. If you care to, you can take a look yourself to see if you notice this effect at: osullivandevelopers.com. I'm running it on my hosting service so the client can check in on the progress directly. I have many other images I have to add, but I want to make sure this modified slider works smoothly. NealO.
  • Neal,

    After checking the file you sent the other day, I'm almost 100% convinced that the full width slider addon you have, is the older buggy version whereby images would jump and not show correctly once scrolled from start to finish. Unfortunately I'm not at my office PC until later this evening but hopefully when Neil picks up on this thread sometime today, he will be able to send you the necessary new files to sort the slider issue out for you.

    Hope this helps
  • I've just emailed the latest addon file over to Neal ;)
  • Cheers Neil, hopefully that will sort Neal out ;-)

    Lol so many neil/neal 's I don't know who's who
  • Haha, no worries.... We're taking over!

    image
  • Thanks, Gents. BTW - that's not Obama! Back to business. I appreciate the newer version of the FWS that you sent along Neil, but that still doesn't resolve the main issue I have with my Home page source code. As reported to Mick further back in this thread, I cannot create an editable area right after (below) Page Body Start. When I insert my cursor next to that green line of code and press Enter, my PC just emits the default PC tone. I'm running WebPlus X8 (16.0.4.32) (64 bit) on a Windows 10 Home O/S. I re-applied the Fix_Webplus_on_Win_10.exe patch just in case Win10 multiple updates overwrote or corrupted the patch. My O/S is totally up-to-date. Next, I opened a separate template and brought up that Home page source code. Show default text is selected. The same issue occurs. Cannot create an editable space below Page Body Start. I can always resort to Mick's work-around by pasting the FWS code text directly into my fragbox. That works except for the images skipping sequence positions - but do you think the newer Asset addon Full-Width-Slider-X7+X8-v1.0.wpack that you provided would fix that behavior? I'm really more interested in knowing why I cannot edit my source code! Could my system be creating this problem? All suggestions would be greatly appreciated. Thanks, all. NealO.
  • Neal,

    If you are getting a ding sound from your system and not able to copy and paste code via the source editor the ONLY thing that is stopping you is because your cursor is in a grey area under the green page body start code, your cursor MUST be in a white area which is an editable area.

    Also if you use the NEW add-on Neil has sent you, then YES this will fix the image jumping and sequence control.

    Hope this helps

  • AAAAAAHHHHHHH!!!!! I wish I'd have figured that out sooner, then this thread would have never existed! As soon as I positioned the cursor in the WHITE area at the END of the Page Body Start code line, I was able to create the edit space I needed. Much thanks to you both Mick & Neil. If I encounter any other issues with the updated FWS addon (which I shouldn't), I'll continue posting to this thread. As of this writing, this thread is now closed.

    Wishing you both a Merry Christmas and a very happy & healthy New Year. NealO

  • No worries Neal, have a good un ;-)

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion